const regex = /(:.*|[^:]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:.*|[^:]*)$', 'gm')
const str = `Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);