import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(vendor\\/devowl-wp\\/[^\\/]+\\/languages\\/frontend\\/json\\/)devowl-wp-";
final String string = "/var/www/html/wp-content/plugins/real-category-library/vendor/devowl-wp/real-product-manager-wp-client/languages/frontend/json/devowl-wp-real-product-manager-wp-client-de_DE_formal-vendor-devowl-wp-real-product-manager-wp-client.json";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}