re = /(vendor\/devowl-wp\/[^\/]+\/languages\/frontend\/json\/)devowl-wp-/m
str = '/var/www/html/wp-content/plugins/real-category-library/vendor/devowl-wp/real-product-manager-wp-client/languages/frontend/json/devowl-wp-real-product-manager-wp-client-de_DE_formal-vendor-devowl-wp-real-product-manager-wp-client.json'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result