const regex = /(vendor\/devowl-wp\/[^\/]+\/languages\/frontend\/json\/)devowl-wp-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(vendor\\\/devowl-wp\\\/[^\\\/]+\\\/languages\\\/frontend\\\/json\\\/)devowl-wp-', 'gm')
const str = `/var/www/html/wp-content/plugins/real-category-library/vendor/devowl-wp/real-product-manager-wp-client/languages/frontend/json/devowl-wp-real-product-manager-wp-client-de_DE_formal-vendor-devowl-wp-real-product-manager-wp-client.json`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);