# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/data-thumb-bg="([^"]+?\.(?:jpe?g|png|gif))"/style="background-image: url(\1);"/g;t' <<< "<div data-thumb-bg=\"photo.jpg\">Foo Bar</div>
<div data-thumb-bg=\"photo.jpeg\">Foo Bar</div>
<div data-thumb-bg=\"photo.png\">Foo Bar</div>
<div data-thumb-bg=\"photo.gif\">Foo Bar</div>
<div data-thumb-bg=\"photo.txt\">Foo Bar</div>"