import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "data-thumb-bg=\"([^\"]+?\\.(?:jpe?g|png|gif))\"";
final String string = "<div data-thumb-bg=\"photo.jpg\">Foo Bar</div>\n"
+ "<div data-thumb-bg=\"photo.jpeg\">Foo Bar</div>\n"
+ "<div data-thumb-bg=\"photo.png\">Foo Bar</div>\n"
+ "<div data-thumb-bg=\"photo.gif\">Foo Bar</div>\n"
+ "<div data-thumb-bg=\"photo.txt\">Foo Bar</div>";
final String subst = "style=\"background-image: url(\\1);\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}