$re = '/data-thumb-bg="([^"]+?\.(?:jpe?g|png|gif))"/';
$str = '<div data-thumb-bg="photo.jpg">Foo Bar</div>
<div data-thumb-bg="photo.jpeg">Foo Bar</div>
<div data-thumb-bg="photo.png">Foo Bar</div>
<div data-thumb-bg="photo.gif">Foo Bar</div>
<div data-thumb-bg="photo.txt">Foo Bar</div>';
$subst = "style=\"background-image: url(\1);\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;