import re
regex = re.compile(r"data-thumb-bg=\"([^\"]+?\.(?:jpe?g|png|gif))\"")
test_str = ("<div data-thumb-bg=\"photo.jpg\">Foo Bar</div>\n"
"<div data-thumb-bg=\"photo.jpeg\">Foo Bar</div>\n"
"<div data-thumb-bg=\"photo.png\">Foo Bar</div>\n"
"<div data-thumb-bg=\"photo.gif\">Foo Bar</div>\n"
"<div data-thumb-bg=\"photo.txt\">Foo Bar</div>")
subst = "style=\"background-image: url(\\1);\""
result = regex.sub(subst, test_str)
if result:
print(result)