#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "data-thumb-bg="([^"]+?\.(?:jpe?g|png|gif))""
Local $sString = "<div data-thumb-bg="photo.jpg">Foo Bar</div>" & @CRLF & _
"<div data-thumb-bg="photo.jpeg">Foo Bar</div>" & @CRLF & _
"<div data-thumb-bg="photo.png">Foo Bar</div>" & @CRLF & _
"<div data-thumb-bg="photo.gif">Foo Bar</div>" & @CRLF & _
"<div data-thumb-bg="photo.txt">Foo Bar</div>"
Local $sSubst = "style="background-image: url(\1);""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)