const regex = /data-thumb-bg="([^"]+?\.(?:jpe?g|png|gif))"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('data-thumb-bg="([^"]+?\\.(?:jpe?g|png|gif))"', 'g')
const str = `<div data-thumb-bg="photo.jpg">Foo Bar</div>
<div data-thumb-bg="photo.jpeg">Foo Bar</div>
<div data-thumb-bg="photo.png">Foo Bar</div>
<div data-thumb-bg="photo.gif">Foo Bar</div>
<div data-thumb-bg="photo.txt">Foo Bar</div>`;
const subst = `style="background-image: url(\1);"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);