using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data-thumb-bg=""([^""]+?\.(?:jpe?g|png|gif))""";
string substitution = @"style=""background-image: url(\1);""";
string input = @"<div data-thumb-bg=""photo.jpg"">Foo Bar</div>
<div data-thumb-bg=""photo.jpeg"">Foo Bar</div>
<div data-thumb-bg=""photo.png"">Foo Bar</div>
<div data-thumb-bg=""photo.gif"">Foo Bar</div>
<div data-thumb-bg=""photo.txt"">Foo Bar</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}