use strict;
my $str = '<div data-thumb-bg="photo.jpg">Foo Bar</div>
<div data-thumb-bg="photo.jpeg">Foo Bar</div>
<div data-thumb-bg="photo.png">Foo Bar</div>
<div data-thumb-bg="photo.gif">Foo Bar</div>
<div data-thumb-bg="photo.txt">Foo Bar</div>';
my $regex = qr/data-thumb-bg="([^"]+?\.(?:jpe?g|png|gif))"/p;
my $subst = 'style="background-image: url(\\1);"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";