# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$/https:\/\/$1\/$2\/$3/gm;t' <<< "C:\Program Files\nodejs\node_modules\test
C:\nodejs\node_modules
C:\Program Files\test\nodejs\node_modules
"