import Foundation
let pattern = #"^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\Program Files\nodejs\node_modules\test
C:\nodejs\node_modules
C:\Program Files\test\nodejs\node_modules
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://$1/$2/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)