using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$";
string substitution = @"https://$1/$2/$3";
string input = @"C:\Program Files\nodejs\node_modules\test
C:\nodejs\node_modules
C:\Program Files\test\nodejs\node_modules
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}