$re = '/^[A-Z]:\\\\(?:[^\\\\\n]*\\\\)*?(?:([^\\\\\n]+)\\\\)?([^\\\\\n]+)\\\\([^\\\\\n]+)$/m';
$str = 'C:\\Program Files\\nodejs\\node_modules\\test
C:\\nodejs\\node_modules
C:\\Program Files\\test\\nodejs\\node_modules
';
$subst = "https://$1/$2/$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;