package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$`)
var str = `C:\Program Files\nodejs\node_modules\test
C:\nodejs\node_modules
C:\Program Files\test\nodejs\node_modules
`
var substitution = "https://$1/$2/$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}