// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$").unwrap();
let string = "C:\\Program Files\\nodejs\\node_modules\\test
C:\\nodejs\\node_modules
C:\\Program Files\\test\\nodejs\\node_modules
";
let substitution = "https://$1/$2/$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}