use strict;
my $str = 'C:\\Program Files\\nodejs\\node_modules\\test
C:\\nodejs\\node_modules
C:\\Program Files\\test\\nodejs\\node_modules
';
my $regex = qr/^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$/mp;
my $subst = 'https://$1/$2/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";