#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[A-Z]:\\(?:[^\\\n]*\\)*?(?:([^\\\n]+)\\)?([^\\\n]+)\\([^\\\n]+)$"
Local $sString = "C:\Program Files\nodejs\node_modules\test" & @CRLF & _
"C:\nodejs\node_modules" & @CRLF & _
"C:\Program Files\test\nodejs\node_modules" & @CRLF & _
""
Local $sSubst = "https://$1/$2/$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)