# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\_POST\[(.*)\]/$1/g;t' <<< "mysql_query (\"UPDATE table SET fill = '$_POST[aaa]' WHERE id = '1'\");
mysql_query (\"UPDATE table SET fill = '$_POST[bbb]' WHERE id = '2'\");
mysql_query (\"UPDATE table SET fill = '$_POST[ccc]' WHERE id = '3'\");
mysql_query (\"UPDATE table SET fill = '$_POST[ddd]' WHERE id = '4'\");
mysql_query (\"UPDATE table SET fill = '$_POST[eee]' WHERE id = '5'\");"