const regex = /\_POST\[(.*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\_POST\\[(.*)\\]', 'g')
const str = `mysql_query ("UPDATE table SET fill = '\$_POST[aaa]' WHERE id = '1'");
mysql_query ("UPDATE table SET fill = '\$_POST[bbb]' WHERE id = '2'");
mysql_query ("UPDATE table SET fill = '\$_POST[ccc]' WHERE id = '3'");
mysql_query ("UPDATE table SET fill = '\$_POST[ddd]' WHERE id = '4'");
mysql_query ("UPDATE table SET fill = '\$_POST[eee]' WHERE id = '5'");`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);