using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\_POST\[(.*)\]";
string substitution = @"$1";
string input = @"mysql_query (""UPDATE table SET fill = '$_POST[aaa]' WHERE id = '1'"");
mysql_query (""UPDATE table SET fill = '$_POST[bbb]' WHERE id = '2'"");
mysql_query (""UPDATE table SET fill = '$_POST[ccc]' WHERE id = '3'"");
mysql_query (""UPDATE table SET fill = '$_POST[ddd]' WHERE id = '4'"");
mysql_query (""UPDATE table SET fill = '$_POST[eee]' WHERE id = '5'"");";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}