import Foundation
let pattern = #"\_POST\[(.*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
mysql_query ("UPDATE table SET fill = '$_POST[aaa]' WHERE id = '1'");
mysql_query ("UPDATE table SET fill = '$_POST[bbb]' WHERE id = '2'");
mysql_query ("UPDATE table SET fill = '$_POST[ccc]' WHERE id = '3'");
mysql_query ("UPDATE table SET fill = '$_POST[ddd]' WHERE id = '4'");
mysql_query ("UPDATE table SET fill = '$_POST[eee]' WHERE id = '5'");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)