// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\_POST\[(.*)\]").unwrap();
let string = "mysql_query (\"UPDATE table SET fill = '$_POST[aaa]' WHERE id = '1'\");
mysql_query (\"UPDATE table SET fill = '$_POST[bbb]' WHERE id = '2'\");
mysql_query (\"UPDATE table SET fill = '$_POST[ccc]' WHERE id = '3'\");
mysql_query (\"UPDATE table SET fill = '$_POST[ddd]' WHERE id = '4'\");
mysql_query (\"UPDATE table SET fill = '$_POST[eee]' WHERE id = '5'\");";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}