$re = '/\_POST\[(.*)\]/';
$str = 'mysql_query ("UPDATE table SET fill = \'$_POST[aaa]\' WHERE id = \'1\'");
mysql_query ("UPDATE table SET fill = \'$_POST[bbb]\' WHERE id = \'2\'");
mysql_query ("UPDATE table SET fill = \'$_POST[ccc]\' WHERE id = \'3\'");
mysql_query ("UPDATE table SET fill = \'$_POST[ddd]\' WHERE id = \'4\'");
mysql_query ("UPDATE table SET fill = \'$_POST[eee]\' WHERE id = \'5\'");';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;