package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\_POST\[(.*)\]`)
var str = `mysql_query ("UPDATE table SET fill = '$_POST[aaa]' WHERE id = '1'");
mysql_query ("UPDATE table SET fill = '$_POST[bbb]' WHERE id = '2'");
mysql_query ("UPDATE table SET fill = '$_POST[ccc]' WHERE id = '3'");
mysql_query ("UPDATE table SET fill = '$_POST[ddd]' WHERE id = '4'");
mysql_query ("UPDATE table SET fill = '$_POST[eee]' WHERE id = '5'");`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}