#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\_POST\[(.*)\]"
Local $sString = "mysql_query ("UPDATE table SET fill = '$_POST[aaa]' WHERE id = '1'");" & @CRLF & _
"mysql_query ("UPDATE table SET fill = '$_POST[bbb]' WHERE id = '2'");" & @CRLF & _
"mysql_query ("UPDATE table SET fill = '$_POST[ccc]' WHERE id = '3'");" & @CRLF & _
"mysql_query ("UPDATE table SET fill = '$_POST[ddd]' WHERE id = '4'");" & @CRLF & _
"mysql_query ("UPDATE table SET fill = '$_POST[eee]' WHERE id = '5'");"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)