using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[propertyID=""[^""]*""\]";
string input = @"[propertyID=""1!%2dfffg3f%--05?00""] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}