// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\[propertyID="[^"]*"\]"#).unwrap();
let string = "[propertyID=\"1!%2dfffg3f%--05?00\"] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}