$re = '/\[propertyID="[^"]*"\]/';
$str = '[propertyID="1!%2dfffg3f%--05?00"] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);