const regex = /\[propertyID="[^"]*"\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[propertyID="[^"]*"\\]', '')
const str = `[propertyID="1!%2dfffg3f%--05?00"] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}