package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[propertyID="[^"]*"\]`)
var str = `[propertyID="1!%2dfffg3f%--05?00"] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}