re = /\[propertyID="[^"]*"\]/
str = '[propertyID="1!%2dfffg3f%--05?00"] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end