import Foundation
let pattern = #"\[propertyID="[^"]*"\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
[propertyID="1!%2dfffg3f%--05?00"] {
fillColor : #f3f1ed;
minSize : 5;
lineWidth : 3;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}