import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[propertyID=\"[^\"]*\"\\]";
final String string = "[propertyID=\"1!%2dfffg3f%--05?00\"] { \n"
+ " fillColor : #f3f1ed;\n"
+ " minSize : 5;\n"
+ " lineWidth : 3;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}