using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(%[SCD-])+$";
string input = @"This will match:
%D%-
%S%C%S
But will not match:
%%D%C
%D%%C
%DD%C
%DC%C";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}