$re = '/^(%[SCD-])+$/m';
$str = 'This will match:
%D%-
%S%C%S
But will not match:
%%D%C
%D%%C
%DD%C
%DC%C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);