// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(%[SCD-])+$").unwrap();
let string = "This will match:
%D%-
%S%C%S
But will not match:
%%D%C
%D%%C
%DD%C
%DC%C";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}