re = /^(%[SCD-])+$/m
str = 'This will match:
%D%-
%S%C%S
But will not match:
%%D%C
%D%%C
%DD%C
%DC%C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end