import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(%[SCD-])+$";
final String string = "This will match:\n"
+ "%D%-\n"
+ "%S%C%S\n\n"
+ "But will not match:\n"
+ "%%D%C\n"
+ "%D%%C\n"
+ "%DD%C\n"
+ "%DC%C";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}