import re
regex = re.compile(r"^(%[SCD-])+$", flags=re.MULTILINE)
test_str = ("This will match:\n"
"%D%-\n"
"%S%C%S\n\n"
"But will not match:\n"
"%%D%C\n"
"%D%%C\n"
"%DD%C\n"
"%DC%C")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")