package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(%[SCD-])+$`)
var str = `This will match:
%D%-
%S%C%S
But will not match:
%%D%C
%D%%C
%DD%C
%DC%C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}