#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "checked=.*?_value\\""
Local $sString = "my regex expression checked=\"someword_and_moreword_value\""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)