import Foundation
let pattern = #"checked=.*?_value\\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"my regex expression checked=\"someword_and_moreword_value\""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)