$re = '/checked=.*?_value\\\\"/';
$str = 'my regex expression checked=\\"someword_and_moreword_value\\"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;