re = /checked=.*?_value\\"/
str = 'my regex expression checked=\\"someword_and_moreword_value\\"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result