using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#([^\s\p{P}]*)\S+";
string substitution = @"<a href=""https://www.facebook.com/hashtag/$1"" title=""$1"">$1</a>";
string input = @"Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}