$re = '/#([^\s\p{P}]*)\S+/m';
$str = 'Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)';
$subst = "<a href=\"https://www.facebook.com/hashtag/$1\" title=\"$1\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;