const regex = /#([^\s\p{P}]*)\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#([^\\s\\p{P}]*)\\S+', 'gm')
const str = `Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)`;
const subst = `<a href="https://www.facebook.com/hashtag/$1" title="$1">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);